GFig Manual

Introduction to Gfig

GFig is a vector drawing tool for the GIMP. Paint programs like the GIMP produce raster graphics, which are simply flat bitmaps, which describe a large set of dots (pixels) with a colour value for each dot. 
Vector graphics programs like Gfig instead describe lines and curves using the points and equations of the lines. 
GFig is be used to create line drawings which can then be turned into brush strokes and applied to your image. GFig can also be used to Paint using the other tools as well as create Selections or Selections Filled a choice of colour or pattern.

If you just need quick help Gfig has Tooltips for almost all options.  To see these hints hover your mouse over the feature you are interested in for a few seconds and they will appear.  When you have learned how to use Gfig the tooltips can be turned off using the "Show Tooltips" checkbox in the Options Tab. 

Gfig can be run by choosing Filters, Render, Gfig from the menu. 
The GFig plugin consists of a single dialog window, which has four main areas, Ops, Preview, Settings, and a row of buttons along the bottom. 

Table of Contents

Known Bugs
Credits


Ops

Ops is an abbreviation for Operations, it lists the available Tools or Operations.

Line

Line Icon

Tool for drawing straight lines. To draw a line using this tool click to select the tool and then click and hold to create the start point of your line and then release to create the end point. You can also create a line with more than two points (a polyline). To create a polyline hold down the Shift Key while you click to create each point, release shift and click to create the end point.

Circle

Cicrle Icon

Tool for drawing a perfect circle. Click to create the centre of the circle and then drag and click to set the size of your circle.

Ellipse

Ellipse Icon

Tool for drawing Ellipses.  As with the circle tool you draw out from the centre point but you can also make the shape narrower on the Horizontal and Vertical axis.  Unfortunately this only allows you an ellipse at the horizontal or at the vertical, there is no way to draw an ellipse with a diagonal slope. 

Curve

Gfig Curve Icon

Tool for drawing Curves or Arcs.  Click to create a start point, a mid-point and an end point.  A regular curve is then drawn along the points. 

Poly

Gfig Polygon Icon

Tool for drawing regular Polygons.   Click to draw a polygon from its centre to one of its points.
Double click on the  Polygon Tool button to get the Tool Properties dialog where you can specify the default number of sides you want your polygon to have (you are allowed between three and two-hundred sides). 
This dialog is labelled "Number of Sides/Points/Turns" because it is reused by the Polygon Tool, Star Tool and Spiral Tool. 

Star

Gfig Star Icon

Tool for drawing regular Stars.   Click to draw a Start from its centre to one of its points.
There is a handle/control point to allow you to adjust the angle between the sides, using the MvPnt Tool. 
Double click on the Star Tool button to get the Tool Properties dialog and where you can specify the default number of sides you want your Star to have (you are allowed between three and two-hundred points). 
This dialog is labelled "Number of Sides/Points/Turns" because it is reused by the Polygon Tool, Star Tool and Spiral Tool. 

Spiral

Gfig Spiral Icon

Tool for drawing Spirals.  Click to draw a spiral from it's centre to an outer end point. 
Double click on the Spiral Tool button to get the Tool Properties dialog where you can specify the default number of turns (you are allowed between one and twenty turns).   There is also the option set the Orientation of the Spiral to default to Clockwise or Anti-Clockwise direction. 
Although the icon looks slightly squared this tool is only for drawing curved spirals and cannot draw squared spirals. 

Bezier

Gfig Bezier Icon

Tool for drawing Bezier Curves.  Bezier curves allow you more points and more control of the curve shape than the standard Curve Tool. 
Double click on the Bezier Tool button to get the Tool Properties dialog.   You can specify if the Bezier Curve is to close back to the start point when finished.  You can also allow the line frame of the bezier curve to be shown to help you adjust the curves more easily. 

Move

Gfig Move Icon

Tool for moving shapes.  Allows you to move a whole line or shape by clicking and dragging a handle/control point.

MvPNT

Gfig Move Point Icon

Tool for Moving Points.  Allows you to move a single point and reshape lines or shapes by clicking or dragging on a handle/control point. 

Copy

Gfig Copy Icon

Tool for Copying Shapes.  Click on a shape handle/control point to copy it.  You should drag before you release the mouse click, because if you a copy a shape and leave it directly above the original shape maybe be obscured and no longer be visible.  See Known Bugs section more information. 

Delete

Gfig Delete Icon

Tool for Deleting Shapes.  Click on the handle/control point of an object to delete it. Be careful, Gfig only provides 4 levels of undo by default . 


The next few buttons behave differently and are not specific tools but rather some special action buttons. 

> Show Next

Shows only the next Object, all other elements of the  Drawing are hidden. 

> Show Previous

Shows only the previous shape or line. 

== Show All

Shows all Objects in the current drawing again. 



Preview

This is the main drawing area in Gfig.  The space is proportional to the size of the image from which you opened Gfig. 
The rulers are always shown and cannot be hidden. 

Object Details

Shows the current X and Y coordinates of  the position of the cursor.  Must be enabled from the Options Tab, using the Show Position check box. 

Collection Details

Shows the Title and filename of the current drawing object. 
Also shows the file name and location on disk for the current drawing object. 

Settings

Object

Prev

Shows a small Thumbnail sized Preview of the drawing object currently selected from the list. 

Edit

Opens the  currently selected  drawing object and displays it in the main Drawing preview area for Editing. 

Merge

Imports the currently selected drawing object and merges it with whatever drawing is already open.  Changes affect the already open drawing, not the document which was merged on top of it. 

Drawing List

A list showing the currently available Gfig Drawings. 

Rescan...

Refreshes the existing list and scans to see if any new gfig files have been added to the gfig folder.  Any Unsaved changes will be lost if you choose Rescan. 
The Rescan Dialog also allows you to add and remove which folders are to be scanned for Gfig object collections. 

Load

Load a single gfig Drawing Object. 

New

Create a New Gfig Drawing Object.   Prompts you for a Name for the new drawing and opens it. 
Note: this does not create a file, you will need to save your Drawing using the Save button. 

Delete

Deletes the currently selected gfig Drawing Object.  Deletes the file on disk and cannot be undone. 


Grid

Snap to Grid

Makes the end points of the line snap to the corners formed by the grid lines. 

Display Grid

Shows a Grid over the main drawing area. 

Lock on Grid

This feature was not implemented at the time of writing.  It will likely be removed in future versions. 



Paint, Brush, Select, Options.

Paint


Draw On: Original, New, Multiple. 
By default Gfig will draw directly on the Original image.  This option allows you to draw to a new layer, or even create a new layer for ever line or shape drawn by gfig.  Drawing directly to the original layer is difficult to undo, and it is easy to run out of undo space.  It is recommended that you draw to a New Layer, because it is easier to remove the whole layer all at once, and you always have the option of merging the layers together later.  See also the section below labelled "With BG of:". 
Using: Brush, Selection, Selection Fill. 
This option is to specify what tool to "Paint" with. 
Brush allows you to paint using various types of brushes.   The detailed settings for this are contained in the Brush Tab. 
Selection allows you to use Gfig to create selections, and Selection Fill gives the extra option of filling the Selection with a Colour or Pattern.  The detailed settings for this are contained in the Select Tab.   The Select Tab is usually hidden, and only appears after you have selected either Selection or Select Fill, form the list. 

With BG of: Transparent, Background, Foreground, White, Copy.
If you have selected either of the "Draw on:" options New or Multiple, this option allows you to specify the type of Background (BG) to be used when the drawing the new Layers.  Transparent, Background, Foreground, and White use the current colour settings. 
Copy causes the previous layer to be copied before the draw is performed. 

Scale to Image
Using the slider you can rezise the current stencil to better fit the image.  Clicking the checkbox will reset the stencil to it's original size. 

Reverse Line
Draw lines in reverse order. 

Approx Circles Ellipses
Approximate circles and ellipses using lines.  Allows the use of brush fading with the circle and ellipse tools. 

Brush

This section allows you to choose which drawing to you want to use when Rendering your drawing. 
The tools include Brush, Pencil, Airbrush, and Pattern and the lower part of this section changes to show the available option for the currently selected tool. 

Select

This section allows you to choose a variety of selection behaviours.  The "Fill" options only apply if you are using Selection Fill (Selection+Fill). 
In older versions of Gfig this section was hidden unless you chose to Paint using Selection (or Selection Fill) from the Paint Tab, then the Selection Tab will appear. 

Options

Show Image will display your original image with your gfig drawing on top of it. 
Reload Image allows you to reload and refresh the image, in case any changes have been made to it. 

Grid Types include Rectangle Grid, Polar Grid, and Isomorphic Grid. 
Rectangle Grid is a fairly standard box grid made of many paralellel horizontal and vertical lines. 
Polar Grid is made up of lines all meeting at a central point or 'pole' and surrounded by equally spaced concentric rings. 
Isometric Grid is made up of paralell vertical lines and a parellel diagonal lines at thirty degrees to the horizontal (a slope of  2:1 )

Max Undo
Allows you to set the maximum amount of Undo steps you want to have in Gfig.  If you are on an older slower machine you might want to save memory by choosing a smaller number of undo levels. 

Show Position
This option allows you to turn off the cursor position information.  This information shows the X and Y position of the cursor and is shown on the lower left of Gfig in the section named 'Object Details'. 

Show/Hide Control Points
This option allows you to hide the Control points, or drag handles.  If your drawing has many control points on it can be useful to hide them temporarily so that you can better see your drawing. 

Show Tooltips
Gfig has extensive tooltips explaining each item which will appear if you hover over an item for a few seconds a short descriptive label will appear.  Advanced users who already know the features of Gfig may want to use this to disable Tooltips. 

About
Shows a dialog containing the version number of Gfig and the name of the Author and contributors. 


Main Buttons

Done

Closes Gfig and warns if any there are any changes to gfig files which have not been saved.

Paint

Paint the Gfig drawing onto the current Image using the currently specified options.  Note that you still use this Button even if you are not painting and are using Gfig to make a selection or another tool which may not strictly be considered "painting". 

Save

If the currently selected Object has unsaved changes a Save Dialog will appear and ask you to provide the name and location to which you want to save your drawing. 

Clear

Wipes the drawing space, clearing any lines or polygons in the currently active Object. 

Undo

Undo the last drawing action made in Gfig. 
By default there are only five levels of Undo and ten is the maximum levels of Undo currently allowed. 

Cancel

Closes Gfig and discards any changes to gfig files which have not been saved.


Known Bugs

There is one major bug known to crash Gfig. 
It occurs if you attempt to use the "Show Image" feature in the Options Tab and only if you have already closed the main image window. 
http://bugzilla.gnome.org/show_bug.cgi?id=124155

Credits

This documenation of Gfig was written by Alan Horkan, for the benifit of both CinePaint (formerly FilmGimp) and the GIMP. 
Gfig originally by Andy Thomas, Isometric Grid by Rob Saunders, Tool Icons by Jakub "Jimmac" Steiner. 
Thanks to who ever wrote the tooltips for Gfig, without which this tasks would have been significantly more difficult.